Skip to main content
CVE-2026-22229VulnerabilityPublished Updated

CVE-2026-22229: TP-Link Systems Archer BE230 v1.2 · OS Command Injection

Affects TP-Link Systems Archer BE230 v1.2Source CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 1.2.4 Build 20251218 rel.70420 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.1% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.4 Build 20251218 rel.70420
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade TP-Link Systems Archer BE230 v1.2 to 1.2.4 Build 20251218 rel.70420.

Affected software

ProductAffectedFixed in
TP-Link Systems Inc.Archer BE230 v1.2Affected
  • =0
Fixed in
  • 1.2.4 Build 20251218 rel.70420
TP-Link Systems Inc.Deco BE25 v1.0Affected
  • =0
Fixed in–

AI-suggested

To mitigate CVE-2026-22229, organizations should immediately upgrade affected devices to the latest firmware versions where the vulnerability is patched (Archer BE230 v1.2 to version 1.2.4 Build 20251218 rel.70420 or later, and Deco BE25 v1.0 to version 1.1.1 Build 20250822 or later). If you cannot patch yet, restrict administrative access to trusted personnel only and enforce strong, unique admin passwords to reduce the risk of credential compromise. Disable VPN client configuration imports if not required or implement strict validation and monitoring of imported files. Employ network segmentation to isolate vulnerable devices from critical infrastructure. Monitor device logs for unusual configuration import activities and commands. Consider deploying network intrusion detection systems to detect anomalous traffic patterns indicative of exploitation attempts. Regularly audit device firmware versions and configurations as part of vulnerability management. Vendor communication channels should be monitored for updates or additional advisories related to this and related vulnerabilities.

Description

A command injection vulnerability may be exploited after the admin's authentication via the import of a crafted VPN client configuration file on the TP-Link Archer BE230 v1.2 and Deco BE25 v1.0. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420 and Deco BE25 v1.0: through 1.1.1 Build 20250822.

References

Community reviews

Loading reviews…