Skip to main content
VulnerabilityPublished Updated

CVE-2026-27601: Underscore Has Unlimited Recursion

Affects underscoreSource GCVE Database

0
Authoritative record:CVE-2026-27601· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 1.13.8 soon.

Data as of 27 Oct 2026, 01:54 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.13.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade underscore to 1.13.8.

Affected software

ProductAffectedFixed in
npmunderscoreAffected
  • <1.13.8
Fixed in
  • 1.13.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Underscore version 1.13.8 or later, which contains a fix for this vulnerability. Alternatively, enforce a depth limit on data structures created from untrusted input (e.g., limit nesting to 1000 levels or fewer). For _.flatten, passing a second argument to limit flattening depth to 1000 or less also mitigates the issue. Ensure exceptions from _.flatten or _.isEqual are properly caught to prevent application crashes.

Description

Underscore versions up to 1.13.7 contain a vulnerability in the _.flatten and _.isEqual functions where unlimited recursion can cause a stack overflow, leading to a denial of service (DoS). This occurs when deeply nested data structures from untrusted input are processed without depth limits. The issue is patched in version 1.13.8. Applications vulnerable to this attack are those that accept deeply nested untrusted input and use these functions without safeguards.

References

Community reviews

Loading reviews…