A vulnerability was determined in Omega Solution Restro POS up to 20261026. This impacts an unknown function of the file /sale-invoice/. Executing a manipulation of the argument productUnitSalePrice can lead to business logic errors. The attack may be performed from remote. The exploit has been publicly disclosed and may be utilized. The vendor was contacted early about this disclosure but did not respond in any way.
HashiCorp Consul and Consul Enterprise 1.17.0 up to 2.0.4 are vulnerable to an authorization bypass in the agent's service mesh leaf certificate API that may allow an attacker without a valid ACL token to retrieve a cached service leaf certificate and its private key. This vulnerability (CVE-2026-105765) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
A memory allocation vulnerability exists in ONNX versions prior to 1.22.0 where unpacking certain tensor types can lead to excessive memory allocation. This occurs because the unpacking functions resize arrays based on attacker-controlled dimensions without verifying the actual encoded data size, potentially causing memory exhaustion. The issue is fixed in version 1.22.0.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Chill Gallery PhotoBlocks photoblocks-grid-gallery allows Stored XSS.This issue affects Gallery PhotoBlocks: from n/a through 1.3.7.
Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in VillaTheme Photo Reviews for WooCommerce woo-photo-reviews allows Leveraging Race Conditions.This issue affects Photo Reviews for WooCommerce: from n/a through 1.2.31.
A signed to unsigned conversion error in ONNX versions from 1.4.0 up to but not including 1.22.0 affects the ScanInferenceFunction and related functions. This flaw allows a missing or negative num_scan_inputs attribute to cause a null pointer dereference or an oversized allocation, potentially disrupting shape inference. The issue is fixed in version 1.22.0.
Missing Authorization vulnerability in VillaTheme Customer Coupons for WooCommerce woo-customer-coupons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Customer Coupons for WooCommerce: from n/a through 1.3.14.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Typing Text – Give your texts many typing effects text-typing allows Stored XSS.This issue affects Typing Text – Give your texts many typing effects: from n/a through 2.2.0.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Button Block button-block allows Stored XSS.This issue affects Button Block: from n/a through 1.2.7.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Content Slider Block content-slider-block allows Stored XSS.This issue affects Content Slider Block: from n/a through 3.2.1.
A vulnerability in ONNX versions from 1.2.1 up to but not including 1.22.0 allows an out-of-bounds read during ConvTranspose shape inference when processing a weight tensor with fewer than three dimensions without a kernel_shape attribute. This can cause the shape inference process to crash, resulting in a denial of service. The issue is fixed in version 1.22.0.
CVE-2026-115919 is an out-of-bounds read vulnerability in the ONNX library prior to version 1.22.0. The issue occurs in the RNNShapeInference_opset1_to_6() function, which improperly processes malformed RNN, LSTM, and GRU nodes without verifying the rank of the first input. This can lead to reading outside the intended protobuf shape fields and cause application termination when processing untrusted models that pass validation. The vulnerability is fixed in ONNX version 1.22.0.
vLLM versions from 0.16.0 up to but not including 0.32.0 contain a vulnerability in the /v1/responses endpoint that allows an authenticated user to supply a malicious template in chat_template_kwargs[chat_template]. This bypasses the intended trust policy and can lead to uncontrolled CPU or memory consumption during Jinja template rendering. The issue is resolved in version 0.32.0.
vLLM versions prior to 0.32.0 have a permissive cross-origin resource sharing (CORS) policy that allows any origin by default. This misconfiguration enables a malicious web page to interact with an unauthenticated vLLM server running on localhost, internal networks, or VPNs, potentially consuming GPU resources and reading responses. The issue is fixed in version 0.32.0.
nforwardauth is a forward auth service that allows the use of a single authentication middleware for multiple sites. Versions prior to 1.5.1 accept an unvalidated `r` query parameter on the `/login` endpoint and use them as the post-authentication redirect destination. An unauthenticated attacker can create a legitimate `nforwardauth` login URL that redirects a victim to an attacker-controlled website after the victim successfully authenticates. This issue may facilitate phishing and other social-engineering attacks by abusing the trust associated with the legitimate authentication domain. This vulnerability does not provide an unauthenticated ForwardAuth bypass. Version 1.5.1 contains a patch.
vLLM versions prior to 0.32.0 contain an off-by-one error in token ID validation that can cause a CUDA device-side assertion failure and engine termination when processing certain pre-tokenized prompts. This vulnerability is fixed in version 0.32.0.
vLLM versions prior to 0.32.0 improperly validate input image data, allowing attacker-controlled image bytes to be passed to Pillow without restricting decoder selection. This can lead to dispatching EPS payloads to host components. If the host environment uses Ghostscript vulnerable to CVE-2024-29510, remote code execution with the vLLM process's privileges is possible. Additionally, environments using Pillow versions 12.0.0 through 12.2.0 can trigger a denial-of-service condition (CVE-2026-59203) by exhausting media-loading workers. The vulnerability is fixed in vLLM version 0.32.0.
CVE-2026-116385 is a cross-site scripting (XSS) vulnerability in Bdtask Garage 24 Garage Management Software version 1.0. The flaw exists in the /edit_profile component, specifically in the handling of the first_name and last_name parameters. This vulnerability can be exploited remotely and requires user interaction. The vendor has not responded to disclosure attempts, and public exploit details are available.
CVE-2026-102649 is a critical vulnerability in padok-team's burrito Kubernetes operator prior to version 0.13.0. It allows unauthenticated attackers to forge GitHub and GitLab webhook events if the webhookSecret is omitted or empty in TerraformRepository credentials. This can lead to unauthorized creation or deletion of TerraformPullRequest resources with attacker-controlled parameters. The flaw enables unauthorized terraform plan operations on affected layers and disclosure of plan results in pull request comments. Auto-apply is disabled, so forced terraform apply is not possible. The issue is fixed in burrito version 0.13.0.
vLLM versions from 0.11.1 up to but not including 0.32.0 contain a reachable assertion vulnerability (CWE-617) in the image processing path for certain OCR models. A remote client with access to the OpenAI-compatible API can submit a specific image that causes a fatal assertion failure, resulting in a shutdown of the inference engine for all users. This denial-of-service condition is fixed in version 0.32.0.