Skip to main content
CVE-2023-32315VulnerabilityPublished Updated

CVE-2023-32315: igniterealtime Openfire · Path Traversal

Affects igniterealtime OpenfireSource CVE Database V5

0

Exploited in the wild · KEV due 14 Sep 2023 · public exploit available (Metasploit) · 99% EPSS : upgrade to 4.7.5 or 4.6.8 now.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else.
EPSS
99.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.7.5, 4.6.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 26 May 2023

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 90 days after disclosure

  4. Observed by OffSeq Mirage: evidence found.

    1 exposed host found; no attack traffic recorded

Timeline

  1. CVE ID reserved

    by GitHub_M

    , 18 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. , 90 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 111 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade org.igniterealtime/openfire to 4.7.5 or 4.6.8.

Affected software

ProductAffectedFixed in
Mavenorg.igniterealtime/openfirepkg:maven/org.igniterealtime/openfireOther threatsAffected
  • <4.6.8
  • <4.7.5
Fixed in
  • 4.6.8
  • 4.7.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2023-32315 is a high-severity path traversal vulnerability in the Openfire XMPP server's administrative console setup environment. It allows unauthenticated attackers to access restricted administrative pages by exploiting improper pathname restrictions. This affects all Openfire versions released since April 2015 up to versions before 4.6.8 and 4.7.5, with patches available in those versions. The vulnerability enables attackers to gain partial administrative access without credentials, potentially compromising confidentiality and availability. No known exploits are currently in the wild, but the ease of exploitation and broad version impact make timely patching critical. European organizations using Openfire should prioritize upgrading to patched versions or apply mitigations from the GitHub advisory.

References

Community reviews

Loading reviews…