Skip to main content
VulnerabilityPublished

CVE-2026-31840: parse-server · SQL Injection

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.6.0-alpha.2 or 8.6.28 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.2, 8.6.28
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.2 or 8.6.28; parse-community/parse-server to 8.6.28.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.2
Fixed in
  • 9.6.0-alpha.2
parse-communityparse-serverAffected
  • <8.6.28
Fixed in
  • 8.6.28
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.28
Fixed in
  • 8.6.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-31840, organizations should immediately upgrade parse-server to version 9.6.0-alpha.2 or later, or 8.6.28 or later if using the 8.x branch. In addition to patching, it is recommended to audit all parse-server deployments to confirm the database backend is PostgreSQL and verify no legacy versions remain in production. Implement network-level protections such as web application firewalls (WAFs) with custom rules to detect and block suspicious query parameters involving dot-notation fields. Employ strict input validation and sanitization on all client inputs interacting with parse-server APIs. Monitor logs for unusual query patterns or errors indicative of attempted SQL injection. Where possible, restrict database user permissions to the minimum necessary to limit the impact of any injection. Finally, conduct penetration testing focused on injection vectors in parse-server query parameters to validate the effectiveness of mitigations.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.

References

Community reviews

Loading reviews…