Skip to main content
VulnerabilityPublished

CVE-2026-31988: thejoshwolfe yauzl · Off-by-one Error

Affects thejoshwolfe yauzlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.2.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade thejoshwolfe yauzl to 3.2.1.

Affected software

ProductAffectedFixed in
thejoshwolfeyauzlAffected
  • >=3.2.0 <3.2.1
Fixed in
  • 3.2.1
npmyauzlpkg:npm/yauzlOther threatsAffected
  • =3.2.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade the yauzl library to version 3.2.1 or later, where the off-by-one error has been fixed. For applications that cannot upgrade immediately, implement input validation to reject zip files containing suspicious or malformed NTFS extra fields before processing. Employ sandboxing or process isolation techniques to limit the impact of potential crashes caused by malformed files. Incorporate robust error handling around calls to entry.getLastModDate() to gracefully handle exceptions without crashing the entire application. Monitor application logs for ERR_OUT_OF_RANGE exceptions or unusual crashes related to zip file processing. Additionally, consider rate limiting or filtering zip file uploads from untrusted sources to reduce exposure. Regularly review and update dependencies to ensure vulnerabilities are patched promptly. Finally, conduct security testing on file upload features to detect similar parsing issues proactively.

Description

CVE-2026-31988 is an off-by-one vulnerability in the yauzl Node.js library version 3.2.0, specifically in the NTFS extended timestamp extra field parser within the getLastModDate() function. The flaw allows a crafted zip file with a malformed NTFS extra field to cause a denial of service by triggering a process crash via an ERR_OUT_OF_RANGE exception. This occurs because the code reads beyond the buffer boundary due to incorrect loop boundary checks. The vulnerability affects any Node.js application that processes zip uploads and calls entry.getLastModDate() on parsed entries. No authentication or user interaction is required to exploit this remotely.

References

Community reviews

Loading reviews…