A heap buffer overflow vulnerability exists in libpng16 affecting the functions png_set_dither and png_set_quantize. This issue is addressed by a security update from the SUSE Product Security Team.
Apache Tomcat and Tomcat Native contain an improper input validation vulnerability in their OCSP response handling. This flaw allows bypassing certificate revocation checks because Tomcat Native and Tomcat's FFM port did not complete verification or freshness checks on OCSP responses. The vulnerability affects multiple versions of Apache Tomcat Native and Apache Tomcat. Fixed versions have been released to address this issue.
This security update for python-urllib3 addresses two vulnerabilities related to resource exhaustion caused by decompression of specially crafted data. CVE-2025-66471 involves excessive resource consumption via decompression of highly compressed data in the Streaming API. CVE-2025-66418 involves resource exhaustion due to an unbounded number of links in the decompression chain. Both issues can lead to denial of service conditions.
A vulnerability in PyTorch's weights_only unpickler allows remote attackers to execute arbitrary code by loading a malicious checkpoint (.pth) file. The flaw involves improper validation of pickle opcodes and storage metadata, leading to heap memory corruption and storage size mismatches. This can be exploited if a user loads a crafted checkpoint file with torch.load(..., weights_only=True). The issue affects PyTorch versions prior to 2.10.0 and is fixed in version 2.10.0.
Lodash versions prior to 4.17.23 and 4.18.0 have a prototype pollution vulnerability in the _.unset, _.omit, and _.pullAt functions. This flaw allows attackers to delete methods from global prototypes by passing crafted paths. The vulnerability permits deletion of properties but does not allow overwriting their original behavior. Patched versions are available starting from 4.17.23 and 4.18.0 depending on the package. No workarounds exist other than upgrading to the fixed versions.
A security update for MariaDB addresses a directory traversal vulnerability that could lead to remote code execution. The fix is included in version 11.8.5. Additional non-security related fixes are also part of this update.
This vulnerability involves improper application of excluded DNS name constraints when verifying wildcard names in the crypto/x509 component of Microsoft software. It affects specific versions 2.0 and 3.0. No CVSS score or detailed impact information is provided, and no known exploits are reported in the wild. No patch or remediation details are available at this time.
The PyPI package 'wallet-tracking' is a malicious cryptocurrency wallet information stealer that collects wallet data from victim hosts and exfiltrates it to an attacker-controlled Discord webhook. It contains no legitimate functionality and all published versions are malicious. The package has been used as a dependency in a GitHub project to steal users' private keys. The source code includes an unconfigured placeholder webhook URL, indicating it is based on a copy-paste stealer template.
CVE-2024-43102 is a critical vulnerability involving concurrent removals of certain anonymous shared memory mappings via the UMTX_SHM_DESTROY sub-request. This can cause the reference count of the shared memory object to be decremented excessively, leading to premature freeing of the object. Exploitation may cause kernel panic or enable use-after-free attacks, potentially resulting in code execution or sandbox escape.
SolarWinds Access Rights Manager contains a critical remote code execution vulnerability (CVE-2024-23471) that allows an authenticated user to execute arbitrary code by abusing a SolarWinds service. This vulnerability has a high impact on confidentiality, integrity, and availability. No affected versions or patch information are currently provided.
SolarWinds Access Rights Manager (ARM) contains a critical directory traversal vulnerability that enables unauthenticated remote code execution with SYSTEM privileges. This flaw allows attackers to perform actions at the highest privilege level on affected systems.
SolarWinds Access Rights Manager (ARM) has a critical remote code execution vulnerability (CVE-2024-23469) that allows an unauthenticated attacker to execute code with SYSTEM privileges. This vulnerability can lead to full compromise of the affected system if exploited.