A vulnerability in the GNSS component allows an out of bounds write due to a missing bounds check. Exploitation requires user interaction and could result in a local denial of service without additional privileges.
A use-after-free vulnerability in the GPU pdma component can lead to local escalation of privilege without requiring additional execution privileges or user interaction.
A vulnerability in the modem component allows an out-of-bounds write due to a missing bounds check. This flaw could enable remote escalation of privilege if a user equipment (UE) connects to a rogue base station controlled by an attacker. Exploitation does not require user interaction or additional execution privileges.
A vulnerability in the GNSS component allows a possible out-of-bounds write due to a missing bounds check. Exploitation requires user interaction and could result in a local denial of service without additional privileges.
A vulnerability in a modem component allows a possible out-of-bounds write due to a missing bounds check. This flaw could enable remote escalation of privilege if a user equipment (UE) connects to a malicious base station controlled by an attacker. Exploitation does not require additional execution privileges or user interaction. A patch has been identified (Patch ID: MOLY01857954), but no public exploit or detailed CVSS score is available.
A path traversal vulnerability exists in deepset-ai farm up to version 0.8.0 in the WordEmbedding_LM.load function within the Model Package Loader component. This vulnerability allows local attackers to manipulate the embeddings_filename argument to access unauthorized file paths. The vulnerability has been publicly disclosed with exploit details available. The affected versions are no longer supported by the maintainer.
A path traversal vulnerability exists in deepset-ai farm versions up to 0.8.0 in the EmbeddingTokenizer.from_pretrained function within farm/modeling/tokenization.py. This flaw allows remote attackers to manipulate the vocab_filename argument to perform path traversal. The vulnerability affects unsupported versions of the product. Exploit code has been published, but no vendor response or patch is available.
A vulnerability in Modem software allows an out of bounds write due to a missing bounds check. This flaw can be exploited remotely by an attacker controlling a rogue base station to escalate privileges on the affected device without requiring user interaction.
A vulnerability in the modem component allows an out of bounds write due to an incorrect bounds check. This flaw can be exploited remotely by an attacker controlling a rogue base station to escalate privileges on the affected device without requiring user interaction.
A path traversal vulnerability exists in Webpro-nl Knip up to version 6.44.0 in the writeFile function of the Workspace Handler component. This flaw allows remote attackers to manipulate the workspaces argument to perform unauthorized file system access. The vulnerability has a medium severity with a CVSS score of 6.3. Public exploit details have been disclosed, but no vendor response or patch is currently available.
A vulnerability in http4k versions from 4.9.10.0 up to but not including 6.60.0.0 allows on-path attackers on non-TLS channels to modify the body of authenticated requests without invalidating the Authorization header. This occurs because the DigestEncoder component does not hash the request entity body when computing the auth-int digest, resulting in a missing integrity check.
A path traversal vulnerability exists in Aklivity Zilla up to versions 1.3.4, 2.4.7, and 2.5.0-rc2 in the Path.resolve function of the FileSystemServerFactory component within the http-filesystem binding. This flaw allows remote attackers to manipulate path parameters to access unauthorized files. Public exploit code is available. Upgrading to version 2.5.0-rc3 addresses this issue.
Network-AI versions from 5.14.0 up to but not including 5.15.5 contain a missing authentication vulnerability in the A2AServer class. This flaw allows unauthenticated attackers to perform task operations such as executing tasks, reading results, and canceling tasks by sending JSON-RPC requests without requiring a Bearer token when no secret is configured.
A path traversal vulnerability exists in http4k versions before 6.62.0.0-ee within the ThymeleafTemplates Caching and HotReload feature. This flaw allows unauthenticated attackers to read arbitrary files outside the intended baseTemplateDir by using '../' segments in ViewModel.template() values. The vulnerability arises because Thymeleaf's FileTemplateResolver resolves escaped paths without proper containment checks, enabling disclosure of any file readable by the server process.
Parse Server versions before 8.6.109 and 9.0.0 before 9.10.6-alpha.1 have a vulnerability where stored field values are returned in object update responses without verifying read access. This allows clients with update permissions but without read permissions to access object data, including atomic operation results and Cloud Code trigger-set values.
Network-AI versions prior to 5.15.5 have a path traversal vulnerability in the InputSanitizer.sanitizePath() function. This flaw allows attackers to escape the intended base directory by using sibling-directory paths that share a string prefix with the base directory. The vulnerability arises because the check to prevent directory traversal uses an unanchored startsWith method, which can be bypassed. Exploitation could allow attackers to read, list, or write files outside the sandboxed environment.
A security flaw in samanhappy MCPHub up to versions 1.0.45 and 1.1.7 allows remote attackers to cause information disclosure via manipulation of the passthroughHeaders argument in src/utils/passthroughHeaders.ts. The issue has been addressed in version 1.1.8.
LobeHub Chat versions from 1.84.26 up to but not including 2.1.49 contain a path traversal vulnerability. Authenticated users can exploit this flaw by supplying unsanitized file names to the writeTempFile() function, enabling arbitrary file writes. This can lead to overwriting critical application files such as startServer.js, potentially resulting in remote code execution or denial of service.
Network-AI versions from 5.13.4 up to but not including 5.15.5 contain a path traversal vulnerability in the AgentVCR component. This flaw allows attackers who can control the cassette name parameter to read or write arbitrary JSON files. Exploitation can lead to disclosure of sensitive JSON data or overwriting of critical policy files such as AuthGuardian trust-level configurations.
Network-AI versions from 5.13.4 up to but not including 5.15.5 contain a path traversal vulnerability in the FileJobStore component. This flaw allows attackers who can control the job id parameter to read or delete arbitrary .json files by using directory traversal sequences. Exploitation can lead to disclosure of sensitive credentials and grant tokens or deletion of configuration files, potentially weakening the authorization mechanism of AuthGuardian.