CVE-2024-7075 is a cross-site scripting (XSS) vulnerability in the user search function of a management console. The function does not properly encode user input before rendering it in the browser, allowing attackers to inject malicious scripts. Exploitation can lead to browser redirection, UI manipulation, or information disclosure from the browser. The vulnerability does not allow session hijacking due to the httpOnly flag on session cookies.
CVE-2026-33818 is a denial of service vulnerability in the Go programming language's encoding/asn1 package. It arises from excessive recursion triggered by a specially crafted, deeply nested ASN.1 structure during the Unmarshal operation. This flaw can be exploited remotely without authentication, potentially causing stack exhaustion and rendering services unavailable. The vulnerability affects OpenShift Virtualization v4.14 images as distributed by Red Hat. No effective mitigation is currently available that meets Red Hat's criteria for ease of use, applicability, or stability.
Dell OpenManage Enterprise versions prior to 4.8.0 contain a Cross-site Scripting (CWE-79) vulnerability. This flaw allows an unauthenticated remote attacker to potentially tamper with information by injecting malicious scripts. The vulnerability has a CVSS 3.1 score of 6.8, indicating a medium severity. A fix is available in version 4.8.0 and later.
The product fails to sufficiently validate callback URLs, allowing them to be manipulated with malicious payloads when processed through a weak regular expression or when validation is omitted.
An attacker can exploit this by crafting a link that appears legitimate but redirects users to an attacker-controlled page. This redirection facilitates phishing attacks, enabling the harvesting of sensitive user information, potentially leading to unauthorized access or data theft.
Dell OpenManage Enterprise, versions prior to 4.8.0, contains an Improper Verification of Cryptographic Signature vulnerability. A high privileged attacker with adjacent network access could potentially exploit this vulnerability, leading to Code execution.
A heap-based buffer overflow vulnerability exists in the SPDY dissector of Wireshark, a network protocol analyzer. This flaw can lead to a denial of service condition. Red Hat has issued a security update addressing this vulnerability in Wireshark packages for Red Hat Enterprise Linux 8 and related products.
Dell OpenManage Enterprise, versions prior to 4.8.0, contains an Improper Neutralization of Argument Delimiters in a Command ('Argument Injection') vulnerability. A low privileged attacker with adjacent network access could potentially exploit this vulnerability, leading to Command execution.
CVE-2026-91910 is a path traversal vulnerability in Dell OpenManage Enterprise versions prior to 4.8.0. It allows a low privileged attacker with adjacent network access to potentially expose sensitive information by improperly restricting pathname access. The vulnerability has a medium severity with a CVSS score of 5.7.
Multiple security vulnerabilities have been identified in the Berkeley Internet Name Domain (BIND) implementation used in Red Hat Enterprise Linux 9. These include denial of service issues via unbounded processing of crafted DNS messages and assertion failures during redirect and RPZ query processing, as well as an arbitrary code execution vulnerability via GSS-TSIG UDP message replay. Red Hat has released security updates addressing these issues.
Dell OpenManage Enterprise, versions prior to 4.8.0, contains an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability. A high privileged attacker with adjacent network access could potentially exploit this vulnerability, leading to Filesystem access for attacker.
A security vulnerability (CVE-2026-32597) exists in the PyJWT library used in Python, where it accepts unknown 'crit' header extensions, violating RFC 7515 section 4.1.11 requirements. This issue has been addressed by Red Hat in an update for python-jwt packages on Red Hat Enterprise Linux 8.8 variants.
Two critical PHP vulnerabilities affect older deployments of Festo Didactic MES4 products using XAMPP with PHP versions up to 7.3, which are out-of-support and unpatched. Mitigations recommended by the PHP foundation include setting memory_limit=-1 and disabling session upload progress in php.ini, with an optional Apache configuration change that impacts performance. Additional firewall restrictions on the Windows host are suggested to limit communication to trusted sources.
The Apache Thrift Rust crate versions prior to 0.23.0 contain a vulnerability in the TBinaryInputProtocol's read_bytes function, where an attacker-controlled 4-byte length value is used directly to allocate a buffer without bounds checking. This can lead to excessive memory allocation or immediate process abort, causing a denial of service. The issue affects any peer sending binary protocol data and is unauthenticated and network-reachable. The vulnerability is fixed in version 0.23.0 by adding checks against negative sizes and enforcing a maximum string size limit.
The refresh token grant type in WSO2 products fails to re-validate account status before issuing new access tokens. This weakness allows an attacker to obtain valid access tokens for user accounts even after they have been blocked by the user store, bypassing account lockout mechanisms.
This vulnerability can lead to unauthorized access to user accounts and their associated resources. Attackers can leverage this to perform actions on behalf of blocked users, potentially leading to privilege escalation or data exfiltration depending on the permissions of the compromised account.
Malicious versions 2.1.312 and 2.1.313 of the Anthropic Claude Code extension were distributed via the Cursor VS Code Extension Marketplace in a supply chain attack. These versions contained JavaScript code that performed host reconnaissance and attempted to establish a reverse SSH tunnel for persistence and remote access. The malicious extension was live for approximately 11 hours and potentially downloaded by around 5,000 developer systems on macOS and Windows. Cursor removed the malicious versions promptly, suspended the marketplace for investigation, rotated keys, and worked with the cloud provider to take down the attacker's server. The attack failed to establish the SSH tunnel on most systems due to lack of administrative privileges. Users are advised to remove the malicious extension versions and follow Cursor's remediation guidance to detect and eliminate persistence mechanisms.
fastify is a web framework for Node.js. In versions 5.8.0 through 5.12.7, when the server is configured with a nonzero handlerTimeout and a route returns a streaming response, a request whose stream has already sent its headers but stays open past the timeout crashes the server. When the timeout fires, Fastify tries to send a new error response on a response that has already started, raising an uncaught ERR_HTTP_HEADERS_SENT that terminates the Node.js process and interrupts any other in-flight requests. An unauthenticated remote client can trigger this with a single request to an affected streaming endpoint, so the impact is availability only, and exploitation requires the non-default handlerTimeout to be set. The default handlerTimeout of 0 is not affected. The issue is fixed in fastify 5.12.8, and users should upgrade to 5.12.8 or later. As a workaround, set handlerTimeout to 0, which disables the affected timeout path.